social.dk-libre.fr is a Fediverse instance that uses the ActivityPub protocol. In other words, users at this host can communicate with people that use software like Mastodon, Pleroma, Friendica, etc. all around the world.
This server runs the snac software and there is no automatic sign-up process.
Mir fiel gerade ein, dass ich vor meiner Abreise vergessen habe mein #NAS zu Hause auszuschalten. Das mache ich sonst immer im Urlaub.
Kein Problem dachte ich mir. Auf der #FritzBox ist ja #VPN Zugang eingerichtet. iPAD meldet aber: „Kein VPN Server gefunden“.
Tja, ich habe ja hinter der FRITZ!Box meinen #openWRT Router laufen. Und in der FRITZ!Box habe ich den im Portforwarding als „Exposed Host“ definiert.
Somit geht alles durch die FRITZ!Box durch, direkt zum openWRT, was von außen ankommt. Ich habe mir damit also quasi einen Ast abgesägt, auf dem ich sitze. Und natürlich funktioniert auch der Fernwartungszugriff auf meine FRITZ!Box nicht mehr, weil Port 443 auch direkt durch die FB durch geht zum openWRT und von dort aus per gezieltem Portforwarding weiter zu meinem #Nginx Proxy Manager, der in meiner #DMZ steht.
Shit happens. Bin halt inmitten der Umstellungsphase meines Netzwerkes. Ich werde mich nach meiner Rückkehr wohl mal um #Wireguard als VPN Zugang kümmern.
Is there a way to debug the (non) connection between a wireguard client inside a FreeBSD Jail, and a remote wireguard server (on a FreeBSD host)?
It looks like nothing gets out of the Jail, so tcpdump is probably not the tool I need right now.
I wish I could get debug logs from the client, but I got nothing.
I've cleaned up my Raspberry Pi selfhosting setup a bit. I'm using two, each in an Argon ONE V5 case with a 1TB NVME drive, running Raspberry Pi OS.
'one' is serving Nextcloud All-in-one, Immich and Vaultwarden via a Caddy reverse-proxy. All using Docker containers, Caddy as a custom build with my domain DNS provider added.
'two' is used as remote borg backup destination for 'one', and later a few monitoring tools.
All three sites are using a wildcard certificate for my domain, and I connect via WireGuard (on the router) when away from home.
Path of least resistance:
I've tried Podman, AlmaLinux, and running a manual install of Nextcloud on Ubuntu. This setup follows recommended installations methods, and gives me fewer things to worry about.
#selfhosting #raspberrypi #nextcloud #immich #vaultwarden #caddy #wireguard
Having followed a tutorial, I could make #WireGuard wg-quick work on my #OpenBSD, but not without DNS query leaks, so I learned I must figure out #unbound - however, a noob like me can only seem to manage to fix configuration errors while unbound itself apparently won't start because of this (which I found out after learning there's more than one way to debug unbound - not elegant, imho):
[1781449588] unbound[95585:0] error: bind: address already in use
[1781449588] unbound[95585:0] fatal error: could not open ports
I figured I should add my VPN interfaces to unbound.conf, but other than that I'm still clueless what else do I need to add or delete.